> My upload is not appearing on the webpage


Whenever I try to upload the zip of my Docker archives nothing seems to be wrong and I get the "Uploaded image!" notification, but nothing happens i.e. I'm unable to delete my image or choose it for submission since it doesn't appear anywhere on the page. And when I refresh the webpage, it's as if I haven't uploaded anything at all.

However, when I tried to upload the example zip from the starting kit "midrc_docker_image_inference_tensorflow_challenge1.zip," that works and I can see it on the website (I also went ahead and submitted it to the challenge). I made sure to follow the exact same structure as the example zip. For example, my zip folder contains my Dockerfile, requirements.txt file, weights file (in HD5 format), and my python/inference script.

I was also able to run my code while running Docker on my own machine.

If there is an issue with one of the files in my zipped folder, I'm unable to tell which one is causing this since the webpage still informs me of "Uploaded image!" without any other errors to the underlying issue.


Posted by: shenmena @ Oct. 12, 2022, 4:08 p.m.

Hi Mena,
sorry to hear this. We will look into your problem of the uploaded Docker zip archive not showing up anywhere but this may take a while. Thank you for your patience.

Posted by: kdrukker @ Oct. 12, 2022, 8:38 p.m.

I saw that you since have successfully uploaded and run your Docker submission, so I assume your issue has been resolved?

Posted by: kdrukker @ Oct. 12, 2022, 9:54 p.m.

No, that was me uploading and submitting the example zip from the starting kit "midrc_docker_image_inference_tensorflow_challenge1.zip." I wanted to make sure it worked to make sure there wasn't a problem completely from my end.

Posted by: shenmena @ Oct. 12, 2022, 11:04 p.m.

Okay, bummer. I will email you so that you can provide some step-by-step screenshots showing what things look like from your end when you try to submit/run your real model. Other participants have been able to upload and run submissions so I am unsure what could be the problem.

Posted by: kdrukker @ Oct. 12, 2022, 11:14 p.m.

Hi Mena,
I verified that your submitted zip file indeed failed to build a Docker Image and thus did not appear under 'Uploaded Images".

What is causing this to happen is somewhere in these lines in your Dockerfile:

# Add a key to apt, so that apt-get update will work, so that we can install opencv-python system dependencies.
RUN apt-key adv --keyserver keyserver.ubuntu.com --recv-keys
RUN apt-get update
# Install opencv-python system dependencies, like Open GL.
RUN apt-get install -y python3-opencv

Since after I removed those, the platform successfully built an Image. I'll leave it up to you to get your Docker Image up and running on the platform and get the desired functionality/dependencies back in there.

(I also removed all the lines with ARG since those did not seem to be used but that was inconsequential.)

Also, to be sure, I'd suggest to always use './[filename]' rather than '[filename]'.

Posted by: kdrukker @ Oct. 13, 2022, 7 p.m.


Keep us posted! :)

Posted by: challenge-organizer @ Oct. 13, 2022, 8:55 p.m.

I was able to upload the image successfully after making your suggested edits, Karen! However, I'm now getting the "Exception('Only one csv file allowed...{}'.format(prediction_files))" error.

Looking at the other threads, it seems like this error is caused by many different things? But, please let me know if it's just erroneous code on my part. I will investigate this more tomorrow as well.


Posted by: shenmena @ Oct. 14, 2022, 1:31 a.m.

Hi Mena,
other submissions have been running fine, so the error likely lies in your code. The error message you are seeing means that your code didn't generate the required csv output file. First thing you can check, assuming your Docker Image runs without error and produces output at home, is that you are not inadvertently trying to access the internet (e.g., to obtain pre-trained weights) which is blocked on the platform.

Posted by: kdrukker @ Oct. 14, 2022, 3:10 p.m.
Post in this thread